数据结构上机测试2-2:单链表操作B

Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数n;
第二行输入n个整数。

Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Sample Input

10
21 30 14 55 32 63 11 30 55 30

Sample Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

#include <stdio.h>
#include <stdlib.h>
struct node
{
    struct node *next;
    int data;
};
struct node *creat(int n)
{
    struct node *head,*p;
    int i;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    for(i=1;i<=n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=head->next;
        head->next=p;
    }
    return (head);
}
void display(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p!=NULL)
    {
        if(p->next==NULL) printf("%d\n",p->data);
        else printf("%d ",p->data);
        p=p->next;
    }
}
int main()
{
    int n;
    struct node *head,*p,*q,*r;
    scanf("%d",&n);
    head=creat(n);
    printf("%d\n",n);
    display(head);
    p=head->next;
    while(p!=NULL)//一个一个结点的看
    {
        r=p;//用r一直往后移,删除重复结点
        q=p->next;//q从p后面开始
        while(q!=NULL)
        {
            if(q->data==p->data)
            {
                n--;
                r->next=q->next;
                free(q);
                q=r->next;
            }
            else
            {
                r=q;
                q=q->next;
            }
        }
        p=p->next;
    }
    printf("%d\n",n);
    display(head);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/waitingac/article/details/81301868