1138数据结构单链表操作A

数据结构上机测试2-1:单链表操作A

Time Limit: 1000 ms Memory Limit: 4096 KiB

Submit Statistic Discuss

Problem Description

输入n个整数,先按照数据输入的顺序建立一个带头结点的单链表,再输入一个数据m,将单链表中的值为m的结点全部删除。分别输出建立的初始单链表和完成删除后的单链表。

Input

第一行输入数据个数n;
第二行依次输入n个整数;
第三行输入欲删除数据m。

Output

第一行输出原始单链表的长度;
第二行依次输出原始单链表的数据;
第三行输出完成删除后的单链表长度;
第四行依次输出完成删除后的单链表数据。

Sample Input

10
56 25 12 33 66 54 7 12 33 12
12

Sample Output

10
56 25 12 33 66 54 7 12 33 12
7
56 25 33 66 54 7 33

Hint

Source


#include<stdio.h>
struct node
{
    int data;
    struct node *next;
};
struct node *str(int n)
{
    int i;
    struct node *head,*p,*tail;
    head=(struct node *)malloc(sizeof(struct node));
    head->next=NULL;
    tail=head;
    for(i=1;i<=n;i++)
    {
        p=(struct node *)malloc(sizeof(struct node));
        scanf("%d",&p->data);
        p->next=NULL;
        tail->next=p;
        tail=p;
    }
    return head;
};

void print(struct node *head)
{
    struct node *p;
    p=head->next;
    while(p)
    {
        if(p==head->next)
        {
            printf("%d",p->data);
        }
        else
            printf(" %d",p->data);
        p=p->next;
    }
    printf("\n");
}

void pr(struct node *head,int n,int m)
{
    struct node *p,*q;
    p=head;
      q=p->next;
    while(q!=NULL)
    {
        if(q->data==m)
        {
            p->next=q->next;
            n--;
        }
        else p=q;
        q=q->next;
    }
    printf("%d\n",n);
    print(head);
}

int main()
{
    int n,m;
    scanf("%d",&n);
    struct node *head;
    head=str(n);
    scanf("%d",&m);
    printf("%d\n",n);
    print(head);
    pr(head,n,m);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/rangran/article/details/81454485