【2018.08.01】(表/栈/队列)

Train Problem I

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2. 
   

InputThe input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input. 
OutputThe output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output. 
Sample Input

3 123 321
3 123 312

Sample Output

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH


        
 
For the first Sample Input, we let train 1 get in, then train 2 and train 3.
So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1.
In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3.
Now we can let train 3 leave.
But after that we can't let train 1 leave before train 2, because train 2 is at the top of the railway at the moment.
So we output "No.".
上面是我的代码,但是超时了,下面是其他人的代码,我去研究研究他的算法吧
#include<iostream>
#include<stack>
#define max 100
using namespace std;
/*int n;
bool step[21];
int main(void)
{
    stack<char> Q;
    int O1sign, O2sign, stepsign;
    char a[10], b[10];
    while ( scanf("%d", &n), n )
    {
        getchar();//防止第一个字符 
        memset( step, false , sizeof(step) ); 
        while ( !Q.empty() ) Q.pop();
        //把堆栈里面清理干净,每一步的step也都清零 
        O1sign=1;    O2sign=1;    stepsign=1;
        //初始化所有数据 
        scanf("%s%s", a+1, b+1);
        while ( 1 )
        {
            if ( a[O1sign]!=b[O2sign] )//如果这两者不相等 
            {
                step[stepsign++]=true;
                Q.push(a[O1sign]); 
                //那么先把O1上的这个字母塞入堆栈
            }
            else//这两个字母相等呢?
            {
                step[stepsign++]=true;
                step[stepsign++]=false;
                O2sign++; 
                //进去了马上就出来了
            }
            if ( O1sign == n ) break;
            //此时已经完成了整个O1的判断,跳出循环 
            O1sign++;
            //不论结果怎样,O1sign都要往后推一格 
        }
        while ( !Q.empty() )
        {
            if ( Q.top() == b[O2sign] )
            {
                Q.pop();
                O2sign++;
                step[stepsign++]=false;
            }
            else break;
        }
        if ( stepsign == 2*n+1 )
        {
            printf("Yes.\n");
            for (int i=1 ; i<=2*n ; i++ )
            {
                if ( step[i] == true ) printf("in\n");
                if ( step[i] == false ) printf("out\n");
            }
            printf("FINISH\n");
        }
        else
        {
            printf("No.\nFINISH\n");    
        }
    }
    return 0;
}*/
int main()
{
    stack<char>s;
    int n,i,j,k,result[max];//n为列车个数, result数组用来表示结果,1表示进栈。0表示出
    char str1[max],str2[max];//序列1和序列2
    while(cin>>n>>str1>>str2)
    {
        j=0,i=0,k=1;
        s.push(str1[0]);//为防止栈空,压一个进去
        result[0]=1;//记录进来了一个。
        while(i<n&&j<n)
        {
            if(s.size()&&s.top()==str2[j])
            {//如果栈顶元素与序列2当前的元素相等,则弹栈,序列2集团向后移一位。
                j++;
                s.pop();
                result[k++]=0;
            }
            else
            {//否则从序列1中取当前元素压入栈中。
                if(i==n)break;
                s.push(str1[++i]);
                result[k++]=1;
            }
        }
        if(i==n)//如果I==N表示栈顶元素不等于序列2当前元素,且序列1中元素都已经入过栈,判断不能得到序列2一样的答案。
            cout<<"No."<<endl;
        else
        {//输出进出栈方式
            cout<<"Yes."<<endl;
            for(i=0; i<k; i++)
                if(result[i])
                    cout<<"in"<<endl;
                else
                    cout<<"out"<<endl;
        }
        cout<<"FINISH"<<endl;
    }
    return 0;
}

猜你喜欢

转载自www.cnblogs.com/mokou/p/9401555.html
今日推荐