Integer Divisibility

If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1's. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3's then, the result is 6, because 333333 is divisible by 7.


Input

Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit (1 ≤ digit ≤ 9).


Output

For each case, print the case numbe

r and the number of digits of such multiple. If several solutions are there; report the minimum one.


Sample Input

3

3 1

扫描二维码关注公众号,回复: 2499185 查看本文章

7 3

9901 1


Sample Output

Case 1: 3

Case 2: 6

Case 3: 12


#include<cstdio>
#include<iostream>
typedef long long ll;
using namespace std;
int main()
{
	int n,i=1;
    scanf("%d",&n);
	while(n--){
		ll a,b,sum=1;
		scanf("%lld%lld",&a,&b);
		ll c=b;
		while(b%=a){   //等价于b%a==0但是更快,就相当于让余数一直增加到能整除为止 
			b=b*10+c;
			sum++;
		}
		printf("Case %d: %lld\n",i++,sum);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/gao506440410/article/details/81186815