nyoj-587 blockhouses(简单DFS)

描述

Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 

输入

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

输出

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

样例输入

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0

样例输出

5
1
5
2
4

题目大意:给出地图,X为墙,放置炮台,若该行或该列有炮台就不能放置,墙隔开不算。求可放置的最大炮台数量。

思路:类似于棋盘皇后问题,思路也差不多,枚举每一个格子,2种状态:放与不放。几个月前学长们出了这道题,当时毫无思路嗑不出来........太菜了,现在也菜。

代码如下:

#include<iostream>
#include<string.h>
#include<queue>
#include<cstdio>
#include<string.h>
using namespace std;
int n,f[4][2]={1,0,-1,0,0,1,0,-1},maxn=-1;
int vis[105][105]={0};
char p[105][105];
void dfs(int z,int s)
{
	int x=z/n,y=z%n;
	if(z==n*n)
	{
		maxn=max(maxn,s);
		return;
	}
	if(p[x][y]=='.')
	{	
		int fag=0;
		for(int i=y;p[x][i]!='X'&&i>=0;i--)//上面的(不用考虑下面的,因为是从上往下从左至右依次枚举,该位置以后都是原状态)
		{
			if(p[x][i]=='Y')
			fag=1;
		} 
		for(int i=x;p[i][y]!='X'&&i>=0;i--)//左边的(同上)
		{
			if(p[i][y]=='Y')
			fag=1;
		}
		if(fag==0)
		{
			p[x][y]='Y';
			dfs(z+1,s+1);
			p[x][y]='.';
		}	
	}
	dfs(z+1,s);
}
int main()
{
	int i,j;
	while(scanf("%d",&n)!=EOF&&n!=0)
	{
		memset(vis,0,sizeof(vis));
		memset(p,0,sizeof(p));
		maxn=-1;
		getchar();
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				cin>>p[i][j];
			}
		}
		dfs(0,0);
		printf("%d\n",maxn);
	}
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/pleasantly1/article/details/81163182