1064 朋友数(PAT 乙级 C++实现)

1064 朋友数(20 point(s))

如果两个整数各位数字的和是一样的,则被称为是“朋友数”,而那个公共的和就是它们的“朋友证号”。例如 123 和 51 就是朋友数,因为 1+2+3 = 5+1 = 6,而 6 就是它们的朋友证号。给定一些整数,要求你统计一下它们中有多少个不同的朋友证号。

输入格式:

输入第一行给出正整数 N。随后一行给出 N 个正整数,数字间以空格分隔。题目保证所有数字小于 10​4​​。

输出格式:

首先第一行输出给定数字中不同的朋友证号的个数;随后一行按递增顺序输出这些朋友证号,数字间隔一个空格,且行末不得有多余空格。

输入样例:

8
123 899 51 998 27 33 36 12

输出样例:

4
3 6 9 26

分析:

用 set 自动有序,然后就就解决了。

详细代码:

#include <iostream>   
#include <set> 
using namespace std;   
  
// 1064 朋友数(20 point(s))
int main(void){  
	int n; cin>>n;

	set<int> a; 
	for(int i=0;i<n;++i){
		int t; cin>>t;

		int sum = 0;
		while(t!=0){
			sum += t%10;
			t /= 10;
		}
		 
		a.insert(sum);
	}
	
	cout<<a.size()<<endl;
	for(set<int>::iterator it=a.begin();it!=a.end();++it){
		if(it!=a.begin()){
			cout<<" ";
		}
		cout<<(*it);
	}

	return 0;
}// jinzheng 2018.7.26 17:38

猜你喜欢

转载自blog.csdn.net/guangjinzheng/article/details/81224859
今日推荐