6486: An Ordinary Game(暴力更新)

6486: An Ordinary Game

时间限制: 1 Sec   内存限制: 128 MB
提交: 150   解决: 75
[ 提交][ 状态][ 讨论版][命题人: admin]

题目描述

There is a string s of length 3 or greater. No two neighboring characters in s are equal.
Takahashi and Aoki will play a game against each other. The two players alternately performs the following operation, Takahashi going first:
Remove one of the characters in s, excluding both ends. However, a character cannot be removed if removal of the character would result in two neighboring equal characters in s.
The player who becomes unable to perform the operation, loses the game. Determine which player will win when the two play optimally.

Constraints
3≤|s|≤105
s consists of lowercase English letters.
No two neighboring characters in s are equal.

输入

The input is given from Standard Input in the following format:
s

输出

If Takahashi will win, print First. If Aoki will win, print Second.

样例输入

aba

样例输出

Second

提示

Takahashi, who goes first, cannot perform the operation, since removal of the b, which is the only character not at either ends of s, would result in s becoming aa, with two as neighboring.


#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;
int main()
{
    char s[100005], ss[100005];
    scanf("%s", s);
    int sum=0, ans=0, len=strlen(s);
    while(1)
    {
        for(int i=1;i<len-1;i++)
        {
            if(s[i]!='\0')
            {
                int x=i-1; 
                while(s[x]=='\0')   x--;
                if(s[x]!=s[i+1])
                {
                    s[i]='\0';
                    sum++;
                }
            }
        }
        int cnt=0;
        for(int i=0;i<len;i++)
            if(s[i]!='\0')
                ss[cnt++]=s[i];
        for(int i=0;i<len;i++)
            s[i]=ss[i];
        len=cnt;
        if(sum==ans)
            break;
        ans=sum;
    }
    if(sum%2)
        printf("First\n");
    else
        printf("Second\n");
    return 0;
} 
/**************************************************************
    Problem: 6486
    User: ldu_reserver201701
    Language: C++
    Result: 正确
    Time:4 ms
    Memory:1168 kb
****************************************************************/

猜你喜欢

转载自blog.csdn.net/qq_30796379/article/details/80498885
今日推荐