Flip Game

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

  

Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;

bool vis[65536+10];
int num;

struct node
{
    int t;
    int step;
    bool operator < ( const node &a ) const
    {
        return a.step<step;
    }
};
void bfs()
{
    queue<node>Q;
    node now,next;
    now.t=num;
    now.step=0;
    Q.push(now);
    while(!Q.empty())
    {
        now=Q.front();
        Q.pop();
        for(int i=0; i<4; i++)
        {
            for(int j=0; j<4; j++)
            {
                int tmp=now.t;
                if(i==0)
                {
                    tmp=tmp^(1<<(11-4*i-j)); //翻转的位置为15-(4*(i+1)+j)
                }
                else if(i==3)
                {
                    tmp=tmp^(1<<(19-4*i-j));//翻转的位置为15-(4*(i-1)+j)
                }
                else
                {
                    tmp=tmp^(1<<(11-4*i-j));
                    tmp=tmp^(1<<(19-4*i-j));
                }

                if(j==0)
                {
                    tmp=tmp^(3<<(14-4*i-j)); //翻转的位置为15-(4*i+j)、15-(4*i+j+1)
                }
                else if(j==3)
                {
                    tmp=tmp^(3<<(15-4*i-j));//翻转的位置为15-(4*i+j-1)、15-(4*i+j)
                }
                else
                {
                    tmp=tmp^(7<<(14-4*i-j)); //翻转的位置为15-(4*i+j-1)、15-(4*i+j)、15-(4*i+j+1)
                }
                next.t=tmp;
                if(next.t==0||next.t==65535) //如果状态已经满足要求直接输出
                {
                    cout<<now.step+1<<endl;
                    return;
                }
                if(!vis[next.t])
                {
                    next.step=now.step+1;
                    vis[next.t]=true;
                    Q.push(next);
                }
            }
        }
    }
    cout<<"Impossible"<<endl;
}

int main()
{
    char str;
    memset(vis,false,sizeof(vis));
    num=0;
    for(int i=0; i<4; i++)
    {
        for(int j=0; j<4; j++)
        {
            cin>>str;
            num<<=1;
            if(str=='b')
                num++;
        }
    }
    if(num==0||num==65535) //如果初始状态已经满足要求直接输出
    {
        cout<<0<<endl;
        return 0;
    }
    else
    {
        vis[num]=true;
        bfs();
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/wu1997___/article/details/81196548