ACM1007: 矩形着色

Description

Danni想为屏幕上的一个矩形着色,但是她想到了一个问题。当点击鼠标以后电脑是如何判断填充的区域呢?

现在给你一个平面直角坐标系,其中有一个矩形和一个点,矩形的四条边均是平行于x轴或y轴的。请你判断这个点相对于矩形的位置,即在矩形内,在矩形上,还是在矩形外?

Input

第一行只有一个整数T,(T < 150),代表共有T种情况。

接下对于每种情况,均有两行数据:

第一行有两个整数Px Py,以空格分隔,代表点的坐标(Px,Py).

第二行有四个整数Ax Ay Bx By,以空格分隔,代表矩形左下角的坐标(Ax,Ay)和右上角的坐标(Bx,By).

所有的坐标均为区间[0,100]内的整数,且Ax<Bx,Ay<By

Output

对于每种情况仅输出一行:

  1. 如果点在矩形外部,请输出”Outside”
  2. 如果点正好在矩形的边上,请输出”On”
  3. 如果点在矩形内部,请输出”Inside” 所有输出都不包含引号。

Sample Input

3
38 7
30 7 52 66
55 1
9 13 54 84
74 67
73 66 76 68

Sample Output

On
Outside
Inside

这是一道水题,题目也是中文的,一般都是可以看懂的。 然后就是画一个坐标系,看一下横坐标和纵坐标的情况,分情况讨论即可,不多说直接上代码吧

#include <iostream>
using namespace std ;
 
void playPos(int Px, int Py, int Ax, int Ay, int Bx, int By){
	if(Px < Ax || Px > Bx || Py < Ay || Py > By){
		cout<<"Outside"<<endl;
	}
	else if(Px == Ax || Px == Bx || Py == Ay || Py == By){
		cout<<"On"<<endl;
	}
	else{
		cout<<"Inside"<<endl;
	}
}
 
int main(){
    int number;
    cin>> number;
    
	for( number; number>0; number--){
		int Px, Py;
		cin>>Px>>Py;
		 
	 	int Ax, Ay, Bx, By;
		cin>>Ax>>Ay>>Bx>>By;
		 
		playPos(Px, Py, Ax, Ay, Bx, By);
	} 
    
	return 0;
}

 如果有改进或者简化的欢迎评论交流

猜你喜欢

转载自blog.csdn.net/qq_41681675/article/details/81234779