A strange lift HDU - 1548(基础广搜)

There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.
Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?
Input
The input consists of several test cases.,Each test case contains two lines.
The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,…kn.
A single 0 indicate the end of the input.
Output
For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.
Sample Input
5 1 5
3 3 1 2 5
0
Sample Output
3
题意:输入n,a,b,和长度为n的k数组。共有n层电梯,求从a层到b层至少按几次电梯。电梯只能按向上或者向下,在i层按上则上升ki层,按下则下降ki层,电梯不能到达1层以下,也不能到达n层以上。
思路:这道算是广搜的基础题了,深搜我试了试,超时。已经走过的楼层就不用走了,如果没有可以走的楼层了还没有到达目标点,那么就是没有办法到达。
代码如下:

#include<bits/stdc++.h>
#define ll long long
#define Pll pair<int,int>
using namespace std;

const int maxx=2e2+10;
int a[maxx],vis[maxx];
int n,s,e;

inline int bfs()
{
	vis[s]=1;
	queue<Pll> q;
	q.push(make_pair(s,0));
	while(q.size())
	{
		Pll u=q.front();
		q.pop();
		if(u.first==e) return u.second;
		int rr=u.first+a[u.first];
		if(rr<=n&&vis[rr]==0) vis[rr]=1,q.push(make_pair(rr,u.second+1));
		rr=u.first-a[u.first];
		if(rr>=1&&vis[rr]==0) vis[rr]=1,q.push(make_pair(rr,u.second+1));
	}
	return -1;
}
int main()
{
	while(scanf("%d",&n),n)
	{
		scanf("%d%d",&s,&e);
		memset(vis,0,sizeof(vis));
		for(int i=1;i<=n;i++) scanf("%d",&a[i]);
		printf("%d\n",bfs());
	}
	return 0;
}

努力加油a啊,(o)/~

发布了652 篇原创文章 · 获赞 101 · 访问量 5万+

猜你喜欢

转载自blog.csdn.net/starlet_kiss/article/details/105305737
今日推荐