派生类习题

编程题

学生CPP成绩计算(10 分)

给出下面的人员基类框架:

class Person {

protected:

     string name;
     int age;

public:

     Person();	  
     Person (string p_name, int p_age);
     void display () {cout<<name<<“:”<<age<<endl;}

};

建立一个派生类student,增加以下成员数据:

int ID;//学号
float cpp_score;//cpp上机成绩
float cpp_count;//cpp上机考勤
float cpp_grade;//cpp总评成绩
     //总评成绩计算规则:cpp_grade = cpp_score * 0.9 + cpp_count * 2;

增加以下成员函数:

student类的无参构造函数

student类的参数化构造函数//注意cpp_grade为上机成绩和考勤的计算结果

void print()//输出当前student的信息

                 //其中cpp_grade输出保留一位小数
                //输出格式为ID name cpp_grade

生成上述类并编写主函数,根据输入的学生基本信息,建立一个学生对象,计算其cpp总评成绩,并输出其学号、姓名、总评成绩。

输入格式: 测试输入包含若干测试用例,每个测试用例占一行(学生姓名 学号 年龄 cpp成绩 cpp考勤)。当读入0时输入结束,相应的结果不要输出。

输入样例:

Bob 10001 18 75.5 4

Mike 10005 17 95.0 5

0

输出样例:

10001 Bob 75.9

10005 Mike 95.5


#include <iostream>
#include <iomanip>
using namespace std;
class Person {
protected:
     string name;
     int age;
public:
     Person()
{
name="abc";
      age=18;
}  
     Person (string p_name, int p_age)
     {
      name=p_name;
age=p_age;
}
     void display () {cout<<name<<":"<<age<<endl;}
};
class student:public Person {
public:
string name;
    int age;
int ID;//学号
float cpp_score;//cpp上机成绩
float cpp_count;//cpp上机考勤
float cpp_grade;//cpp总评成绩
student()
{
ID=001;
name="abc";
      age=18;
cpp_score=0;
cpp_count=0;
cpp_grade=0;
}  
     void modify(int ID1,string name1,int age1,float cpp_score1,float cpp_count1)
     {
      ID=ID1;
      name=name1;
      age=age1;
cpp_score=cpp_score1;
cpp_count=cpp_count1;
cpp_grade=cpp_score1 * 0.9 + cpp_count1 * 2;
}
     void print()
     {
      cout<<ID<<" "<<name<<" "<<setiosflags(ios::fixed)<<setprecision(1)<<cpp_grade<<endl;
}
};


int main() 
{
int i=0,n;
string name[50];
int age[50];
int ID[50];//学号
float cpp_score[50];//cpp上机成绩
float cpp_count[50];//cpp上机考勤
student s[50];
cin>>name[i];


while(name[i]!="0")
{
cin>>ID[i]>>age[i]>>cpp_score[i]>>cpp_count[i];
s[i].modify(ID[i],name[i],age[i],cpp_score[i],cpp_count[i]);
i++;
cin>>name[i];
}
for(n=0;n<i;n++)
s[n].print();
    return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_40161974/article/details/79917507