ACM_八皇后 Heuristic Search - 8 Queens Problem

http://judge.u-aizu.ac.jp/onlinejudge/description.jsp?id=ALDS1_13_A
Heuristic Search - 8 Queens Problem

Time Limit : 1 sec, Memory Limit : 131072 KB

8 Queens Problem
The goal of 8 Queens Problem is to put eight queens on a chess-board such that none of them threatens any of others. A queen threatens the squares in the same row, in the same column, or on the same diagonals as shown in the following figure.

这里写图片描述

For a given chess board where kk queens are already placed, find the solution of the 8 queens problem.

Input

In the first line, an integer kk is given. In the following kk lines,
each square where a queen is already placed is given by two integers
rr and cc. rr and cc respectively denotes the row number and the
column number. The row/column numbers start with 0.

Output

Print a 8×88×8 chess board by strings where a square with a queen is
represented by ‘Q’ and an empty square is represented by ‘.’.

Constraints

There is exactly one solution

Sample Input 1

2
2 2
5 3

Sample Output 1

……Q.
Q…….
..Q…..
…….Q
…..Q..
…Q….
.Q……

#include<iostream>
#include<cassert>
using namespace std;

#define N 8//边长 
#define FREE -1//不受攻击 
#define NOT_FREE 1//受到攻击 

int row[N],col[N],dpos[2*N-1],dneg[2*N-1];//行、列、斜向左下、斜向右下
bool X[N][N];

void initialize()//初始化
{
    for(int i=0;i<N;i++){row[i]=FREE,col[i]=FREE;}
    for(int i=0;i<2*N-1;i++){dpos[i]=FREE;dneg[i]=FREE;}
}

void printBoard()
{
    for(int i=0;i<N;i++)
    {
        for(int j=0;j<N;j++)
        {
            if (X[i][j])
            {
                if(row[i]!=j)
                return;
            }         
        }
    }   
    for(int i=0;i<N;i++)
    {
        for(int j=0;j<N;j++)
        {
            cout<<((row[i]==j)? "Q":".");
        }
        cout<<endl;
    }
}

void recursive(int i)//递归 
{
    if(i==N)//成功放置皇后 
    {
        printBoard();
        return;
    }
    for(int j=0;j<N;j++)//如果(i,j)受到其他皇后攻击,则忽略该格子 
    {
        if(NOT_FREE==col[j]||NOT_FREE==dpos[i+j]||NOT_FREE==dneg[i-j+N-1])
            continue;
        //在(i,j)放置后
        row[i]=j;col[j]=dpos[i+j]=dneg[i-j+N-1]=NOT_FREE; 
        //尝试下一行
        recursive(i+1);
        //(i,j)拿掉摆放在(i,j)的皇后
        row[i]=col[j]=dpos[i+j]=dneg[i-j+N-1]=FREE;
    }
    //皇后放置失败 
}

int main()
{
    initialize();
    for(int i=0;i<N;i++)
        for(int j=0;j<N;j++)
            X[i][j]=false;
    int k;cin>>k;
    for(int i=0;i<k;i++)
    {
        int r,c;cin>>r>>c;
        X[r][c]=true;
    } 
    recursive(0);
    return 0;
}
/*
2
2 2
5 3
*/

猜你喜欢

转载自blog.csdn.net/aaakkk_1996/article/details/79341975