求1000以内n!(没看懂)hduoj1042

N!

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 91321    Accepted Submission(s): 27064


Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
 
  
1 2 3
 

Sample Output
 
  
1 2 6
 代码:
#include <stdio.h>
int main()
{
    int n,i,j;
    while(~scanf("%d",&n))
 {
     int f[50000],a[50000]={1,1};
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=a[0];j++)
        {
            a[j]=a[j]*i+f[j];
            f[j]=0;
            if(a[j]>=10)
            {
                f[j+1]=f[j+1]+a[j]/10;
                a[j]=a[j]%10;
                if (j==a[0])
                    a[0]++;
            }
        }
    }
    for (i=a[0];i>0;i--)
        printf("%d",a[i]);
        printf("\n");
 }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/nanfengzhiwoxin/article/details/80718142
今日推荐