PTA 7-13 出租

7-13 出租(20 分)

下面是新浪微博上曾经很火的一张图:

一时间网上一片求救声,急问这个怎么破。其实这段代码很简单,index数组就是arr数组的下标,index[0]=2 对应 arr[2]=1index[1]=0 对应 arr[0]=8index[2]=3 对应 arr[3]=0,以此类推…… 很容易得到电话号码是18013820100

本题要求你编写一个程序,为任何一个电话号码生成这段代码 —— 事实上,只要生成最前面两行就可以了,后面内容是不变的。

输入格式:

输入在一行中给出一个由11位数字组成的手机号码。

输出格式:

为输入的号码生成代码的前两行,其中arr中的数字必须按递减顺序给出。

输入样例:

18013820100

输出样例:

int[] arr = new int[]{8,3,2,1,0};
int[] index = new int[]{3,0,4,3,1,0,2,4,3,4,4};
#include "algorithm"
#include "set"
#include "vector"
#include "iostream"
#include "cstdio"

using namespace std;

const int maxn = 11 + 10;

int main() {
    set<int, greater<int> > st;
    vector<int> phone;
    int tmp;
    string str;
    getline(cin, str);
    for(int i = 0; i < str.length(); i++){
        phone . push_back(str[i]-'0');
        st.insert(str[i] - '0');
    }
    set<int>::iterator it = st . begin();
    int index[maxn] = {0};
    tmp = 0;
    int tmpindex = *it;
    index[tmpindex] = tmp++;
    cout << "int[] arr = new int[]{" << *it++;
    for (; it != st . end(); it++) {
        cout << "," << *it;
        tmpindex = *it;
        index[tmpindex] = tmp++;
    }
    cout << "};" << endl;
    cout << "int[] index = new int[]{" << index[phone[0]];
    for (int i = 1; i < phone . size(); i++) {
        cout << "," << index[phone[i]];
    }
    cout << "};" << endl;
    
    return 0;
}

猜你喜欢

转载自blog.csdn.net/gaiya2050/article/details/81151911