Anagrams by Stack 【HDU - 1515】

How can anagrams result from sequences of stack operations? There are two sequences of stack operators which can convert TROT to TORT:

[
i i i i o o o o
i o i i o o i o
]

where i stands for Push and o stands for Pop. Your program should, given pairs of words produce sequences of stack operations which convert the first word to the second.

A stack is a data storage and retrieval structure permitting two operations:

Push - to insert an item and
Pop - to retrieve the most recently pushed item
We will use the symbol i (in) for push and o (out) for pop operations for an initially empty stack of characters. Given an input word, some sequences of push and pop operations are valid in that every character of the word is both pushed and popped, and furthermore, no attempt is ever made to pop the empty stack. For example, if the word FOO is input, then the sequence:

i i o i o o is valid, but
i i o is not (it's too short), neither is
i i o o o i (there's an illegal pop of an empty stack)

Valid sequences yield rearrangements of the letters in an input word. For example, the input word FOO and the sequence i i o i o o produce the anagram OOF. So also would the sequence i i i o o o. You are to write a program to input pairs of words and output all the valid sequences of i and o which will produce the second member of each pair from the first.

  • Input

The input will consist of several lines of input. The first line of each pair of input lines is to be considered as a source word (which does not include the end-of-line character). The second line (again, not including the end-of-line character) of each pair is a target word. The end of input is marked by end of file.

Output

For each input pair, your program should produce a sorted list of valid sequences of i and o which produce the target word from the source word. Each list should be delimited by

[
]

and the sequences should be printed in "dictionary order". Within each sequence, each i and o is followed by a single space and each sequence is terminated by a new line.

  • Sample Input
madam
adamm
bahama
bahama
long
short
eric
rice
  • Sample Output
[
i i i i o o o i o o 
i i i i o o o o i o 
i i o i o i o i o o 
i i o i o i o o i o 
]
[
i o i i i o o i i o o o 
i o i i i o o o i o i o 
i o i o i o i i i o o o 
i o i o i o i o i o i o 
]
[
]
[
i i o i o i o o 
]
  • 代码【加题解】:
#include<stdio.h>
#include<string.h>
#include<stack>
using namespace std;

stack<char>s;     // 栈 

char t1[99999],t2[99999],way[999999];
int l1,l2;

void dfs(int x,int y,int k)  // t1的下标 j:t2的下标 k 
{
    if(y==l2)                //满足条件输出一个 
    {
        for(int l=0; l<k; l++)
            printf("%c ",way[l]);
        printf("\n");
        return ;              //返回最近一次调用 
    }
    if(x!=l1)
    {
        s.push(t1[x]);                 //输进去 
        way[k]='i';
        dfs(x+1,y,k+1);                    //
        s.pop();
    }
    if(!s.empty())
    {
        if(s.top()==t2[y])
        {
            way[k]='o';             //找到 ,返回上一个 
            s.pop();
            dfs(x,y+1,k+1);              //下一个 
            s.push(t2[y]);
        }
    }
}
int main()
{
    while(~scanf("%s%s",t1,t2))
    {
        l1=strlen(t1);
        l2=strlen(t2);
        printf("[\n");
        dfs(0,0,0);           //搜索 
        printf("]\n");
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/meant_to_be/article/details/81099594
今日推荐