Network Saboteur(题意理解困难,DFS练习)

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).
Output file must contain a single integer -- the maximum traffic between the subnetworks.

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

题目大意:给出n个点和一个矩阵,矩阵数据表示各点之间的流量,要求将点分成2个集合,相同集合内的点之间流量为0,求两集合各点流量和最大。

例如1.2.3三个点那可以分成(1.2)与(3)  (1.3)与(2) (1)与(2.3) 这三种分法,以第二种情况为例,求流量和即为求1->2+3->2的值 

思路:01标记该点的状态(集合)。DFS暴力搜索最大流量和。感觉懂了题意后直接暴就行了,不懂题意真的是绝望。

扫描二维码关注公众号,回复: 2259670 查看本文章

代码如下:

#include<iostream>
#include<algorithm>
#include<string.h>
#include<string>
#include<queue>
#include<stdio.h>
using namespace std;
int vis[25],p[25][25],a,maxn=0;
void dfs(int x)
{
	if(x==a+1)
	{
		int s=0;
		for(int i=1;i<=a;i++)
		{
			if(vis[i]==1)
			{
				for(int j=1;j<=a;j++)
				{
					if(vis[j]==0)
					{
						s+=p[i][j]; 
					}
				}
			}
		}
		maxn=max(maxn,s);
		return ;
	}
	for(int i=0;i<2;i++)
	{
		vis[x]=i;
		dfs(x+1);
	} 
}
int main()
{
	scanf("%d",&a);
	for(int i=1;i<=a;i++)
	{
		for(int j=1;j<=a;j++)
		{
			scanf("%d",&p[i][j]);
		}
	}
	dfs(1);
	printf("%d",maxn);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/pleasantly1/article/details/81028844
今日推荐