1170-Balloon Comes! JAVA

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 33537    Accepted Submission(s): 12646


Problem Description
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.
Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.
Is it very easy?
Come on, guy! PLMM will send you a beautiful Balloon right now!
Good Luck!
 

Input
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of course, we all know that A and B are operands and C is an operator.
 

Output
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.
 

Sample Input
 
  
4 + 1 2 - 1 2 * 1 2 / 1 2
 

Sample Output
 
  
3 -1 2 0.50
 


import java.util.*;
public class Main
{
	public static void main(String args[])
	{
		Scanner cin=new Scanner(System.in);
		int t=cin.nextInt();
		while(t-->0)
		{
			char c=cin.next().charAt(0);
			int a=cin.nextInt();
			int b=cin.nextInt();
			if(c=='+')System.out.print(a+b);
			else if(c=='-')System.out.print(a-b);
			else if(c=='*')System.out.print(a*b);
			else if(c=='/')
			{
				if(a%b==0)
					System.out.print(a/b);
				else
					System.out.printf("%.2f",(float)a/b);
			}
			System.out.println();
		}
	}
}

猜你喜欢

转载自blog.csdn.net/xiaoyao_zhang/article/details/80023954