全排列next_permutation(c,c+a)

Ignatius and the Princess II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9858    Accepted Submission(s): 5760



Problem Description
Now our hero finds the door to the BEelzebub feng5166. He opens the door and finds feng5166 is about to kill our pretty Princess. But now the BEelzebub has to beat our hero first. feng5166 says, "I have three question for you, if you can work them out, I will release the Princess, or you will be my dinner, too." Ignatius says confidently, "OK, at last, I will save the Princess."

"Now I will show you the first problem." feng5166 says, "Given a sequence of number 1 to N, we define that 1,2,3...N-1,N is the smallest sequence among all the sequence which can be composed with number 1 to N(each number can be and should be use only once in this problem). So it's easy to see the second smallest sequence is 1,2,3...N,N-1. Now I will give you two numbers, N and M. You should tell me the Mth smallest sequence which is composed with number 1 to N. It's easy, isn't is? Hahahahaha......"
Can you help Ignatius to solve this problem?
 

Input
The input contains several test cases. Each test case consists of two numbers, N and M(1<=N<=1000, 1<=M<=10000). You may assume that there is always a sequence satisfied the BEelzebub's demand. The input is terminated by the end of file.
 

Output
For each test case, you only have to output the sequence satisfied the BEelzebub's demand. When output a sequence, you should print a space between two numbers, but do not output any spaces after the last number.
 

Sample Input
 
  
6 4 11 8
 

Sample Output
 
  
1 2 3 5 6 4 1 2 3 4 5 6 7 9 8 11 10

 题意:给你N个整数,分别是1,2,3,。。。N。问你全排列

的第M个排列为多少?

next-permutation 全排列算法

#include<iostream>
#include<algorithm>
using namespace std;
int main() {
	int ans[4]= {1,2,3,4};
	sort(ans,ans+4);    /* 这个sort可以不用,因为{1,2,3,4}已经排好序*/
	do {                           /*注意这步,如果是while循环,则需要提前输出*/
		for(int i=0; i<4; ++i)
			cout<<ans[i]<<" ";
		cout<<endl;
	} while(next_permutation(ans,ans+4));
	return 0;
}


#include<iostream>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<cstdio>
#define N 0x3f3f3f
#include<queue>
using namespace std;
int c[1010];
int main()
{
	int a,b;
	while(cin>>a>>b)
	{
		int h=0;
		memset(c,0,sizeof(c));
		for(int i=0;i<a;i++)
		{
			c[i]=i+1;
		}
		while(next_permutation(c,c+a))
		{
			h++;
			if(h==b-1)
			{
				cout<<c[0];
				for(int i=1;i<a;i++)
            	cout<<" "<<c[i];
        		cout<<endl;
				break;
			}
		}
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/henucm/article/details/79863412
今日推荐