判断两线段相交

You can Solve a Geometry Problem too

  HDU - 1086

Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very easy, after all we are now attending an exam, not a contest :) 
Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point. 

Note: 
You can assume that two segments would not intersect at more than one point. 
InputInput contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s ending. 
A test case starting with 0 terminates the input and this test case is not to be processed. 
OutputFor each case, print the number of intersections, and one line one case. 
Sample Input
2
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.00
3
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.000
0.00 0.00 1.00 0.00
0
Sample Output
1
3
#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;
struct line
{
	double x1,y1,x2,y2;
}node[110];
// 判断两条线段是否存在交点
bool solve(line a,line b)
{
	//设直线AB的方程为:f(x,y) = 0, 当C和D点不在直线的同侧时,
	//直线AB必然与线段CD相交,也就是说直线AB与线段CD相交的条件为:
	//f(C) * f(D) <= 0
	// A(x1, y1), B(x2, y2)的直线方程为:  
    // f(x, y) =  (y - y1) * (x1 - x2) - (x - x1) * (y1 - y2) = 0  
    if(((a.x1-b.x1)*(a.y2-b.y1)-(a.x2-b.x1)*(a.y1-b.y1))*((a.x1-b.x2)*(a.y2-b.y2)-(a.x2-b.x2)*(a.y1-b.y2))>0) return false;
    if(((b.x1-a.x1)*(b.y2-a.y1)-(b.x2-a.x1)*(b.y1-a.y1))*((b.x1-a.x2)*(b.y2-a.y2)-(b.x2-a.x2)*(b.y1-a.y2))>0) return false;
    return true;
}  
int main()
{

        int n;

        while(scanf("%d",&n)&&n)

	{
		for(int i = 0; i < n ; i++)
			scanf("%lf%lf%lf%lf",&node[i].x1,&node[i].y1,&node[i].x2,&node[i].y2);
		int sum = 0;
		for(int i = 0; i < n; i++)
			for(int j = i+1; j < n; j++)
				if(solve(node[i],node[j]))
					sum++;
		printf("%d\n",sum);
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/Nothing_227/article/details/80586141
今日推荐