Tickets C++

题目:

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible. 
A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time. 
Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full of appreciation for your help. 
InputThere are N(1<=N<=10) different scenarios, each scenario consists of 3 lines: 
1) An integer K(1<=K<=2000) representing the total number of people; 
2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person; 
3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together. 
OutputFor every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm. 
Sample Input
2
2
20 25
40
1
8
Sample Output
08:00:40 am
08:00:08 am

思路:

买票,可以一个人一个人买,也可以两个人一起买,看哪个时间短。挺简单的。

递推方程:dp[i]=min(dp[i-1]+si[i],dp[i-2]+di[i-1])。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
void time(int a)
{
    int h,m,s;
    s=a%60;
    a=a/60;
    m=a%60;
    h=a/60+8;
    h=h%24;
    if(h<=12)printf("%02d:%02d:%02d am\n",h,m,s);
    else printf("%02d:%02d:%02d pm\n",h-12,m,s);
}
int main()
{
    int n,k,i;
    int dp[2001];
    cin>>n;
    while(n--)
    {
        cin>>k;
        int si[2001],di[2001];
        memset(si,0,sizeof(si));
        memset(di,0,sizeof(di));
        for(i=1;i<=k;i++)
        {
            scanf("%d",&si[i]);
        }
        for(i=1;i<=k-1;i++)
        {
            scanf("%d",&di[i]);
        }
        memset(dp,0,sizeof(dp));
        for(i=1;i<=k;i++)
        {
            if(i==1)dp[i]=si[i];
            else if(i==2)dp[i]=min(dp[i-1]+si[i],di[i-1]);
            else dp[i]=min(dp[i-1]+si[i],dp[i-2]+di[i-1]);
        }
        time(dp[k]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/zero_979/article/details/80639505