HDU 1236

链接:http://acm.hdu.edu.cn/showproblem.php?pid=1236

排名

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 26743    Accepted Submission(s): 10014


Problem Description
今天的上机考试虽然有实时的Ranklist,但上面的排名只是根据完成的题数排序,没有考虑
每题的分值,所以并不是最后的排名。给定录取分数线,请你写程序找出最后通过分数线的
考生,并将他们的成绩按降序打印。
 

Input
测试输入包含若干场考试的信息。每场考试信息的第1行给出考生人数N ( 0 < N
< 1000 )、考题数M ( 0 < M < = 10 )、分数线(正整数)G;第2行排序给出第1题至第M题的正整数分值;以下N行,每行给出一
名考生的准考证号(长度不超过20的字符串)、该生解决的题目总数m、以及这m道题的题号
(题目号由1到M)。
当读入的考生人数为0时,输入结束,该场考试不予处理。
 

Output
对每场考试,首先在第1行输出不低于分数线的考生人数n,随后n行按分数从高
到低输出上线考生的考号与分数,其间用1空格分隔。若有多名考生分数相同,则按他们考
号的升序输出。
 

Sample Input
 
   
4 5 25 10 10 12 13 15 CS004 3 5 1 3 CS003 5 2 4 1 3 5 CS002 2 1 2 CS001 3 2 3 5 1 2 40 10 30 CS001 1 2 2 3 20 10 10 10 CS000000000000000001 0 CS000000000000000002 2 1 2 0
 

Sample Output
 
   
3 CS003 60 CS001 37 CS004 37 0 1 CS000000000000000002 20
Hint
Huge input, scanf is recommended.


没过竟是因为string,导致编译错误。
#include<iostream>

#include<algorithm>
#include<string>
#include<cstring>
using namespace std;
int n,m,g,k[15];
struct node
{
    int grade;
    string str;
}pp[1005];
bool cmp(node x,node y)
{
    if(x.grade==y.grade) return x.str<y.str;
    else return x.grade>y.grade;
}
int main()
{
    while(cin>>n)
    {
        if(!n) break;
        cin>>m>>g;
        int i,j,temp,ss,sum2=0;
        memset(k,0,sizeof(k));
        for(i=1;i<=m;i++) cin>>k[i];
        for(i=0;i<n;i++)
        {
            cin>>pp[i].str>>temp;
            pp[i].grade=0;
            while(temp--)
            {
                cin>>ss;
                pp[i].grade+=k[ss];
            }
            if(pp[i].grade>=g) sum2++;
        }
        cout<<sum2<<endl;
        if(sum2)
        {
            sort(pp,pp+n,cmp);
            for(i=0;i<n;i++)
            {
                if(pp[i].grade>=g) cout<<pp[i].str<<" "<<pp[i].grade<<endl;
                else break;
            }
        }
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/dadaguai001/article/details/79969966
今日推荐