[PAT] Heap 判断大小根堆

题目如下:


In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at https://en.wikipedia.org/wiki/Heap_(data_structure))

Your job is to tell if a given complete binary tree is a heap.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: M ( 100), the number of trees to be tested; and N (1 < N 1,000), the number of keys in each tree, respectively. Then M lines follow, each contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification:

For each given tree, print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all. Then in the next line print the tree's postorder traversal sequence. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line.

Sample Input:

3 8
98 72 86 60 65 12 23 50
8 38 25 58 52 82 70 60
10 28 15 12 34 9 8 56

Sample Output:

Max Heap
50 60 65 72 12 23 86 98
Min Heap
60 58 52 38 82 70 25 8
Not Heap
56 12 34 28 9 8 15 10


就是给一个堆,判断是大根堆还是小根堆,然后输出它的后序遍历序列。关于堆和堆排序我这几天就写篇文章介绍一下。

给的原始数据是数组形式,所以用到堆的数组表示,从1开始,i左右孩子分别是2*i和2*i+1,写个判定抠一下边界,判断孩子在不在范围内。给的数据没有相等的,就先判定第1、2个元素的大小,把flag标志置为1(大根)或-1(小根),之后如果有一对父子违反大根/小根堆的堆序性,就不是堆,flag=0。最后对照flag输出结果就行了。

#include <iostream>
#include <vector>
using namespace std;
int m, n;
vector<int> v;
void postOrder(int i) {
	if (i > n) return;
	postOrder(i * 2);
	postOrder(i * 2 + 1);
	printf("%d%s", v[i], i == 1 ? "" : " ");
}//后序遍历
int main() {
	scanf("%d%d", &m, &n);
	v.resize(n + 1);
	for (int i = 0; i < m; i++) {
		for (int j = 1; j <= n; j++) {
			scanf("%d", &v[j]);
		}
		int flag = v[1] > v[2] ? 1 : -1; //由第1,2个元素判定堆序
		for (int j = 1; j <= n / 2 + 1; j++) {
			int left = j * 2, right = j * 2 + 1;//堆的数组表示
			if (flag == 1 && ((left <= n && v[j] < v[left]) || (right <= n && v[j] < v[right]))) flag = 0;//大根堆的判定
			if (flag == -1 && ((left <= n && v[j] > v[left]) || (right <= n && v[j] > v[right]))) flag = 0;//小根堆的判定
		}
		if (flag == 0) {
			printf("Not Heap\n");
		}
		else if(flag == 1){
			printf("Max Heap\n");
		}
		else {
			printf("Min Heap\n");
		}
		postOrder(1);
		printf("%s", "\n");
	}
	return 0;
}


猜你喜欢

转载自blog.csdn.net/daniel_2046/article/details/80963737