[次小生成树Prim] Is There A Second Way Left? UVA 10462

Nasa, being the most talented programmer of his time, can’t think things to be so simple. Recently all
his neighbors have decided to connect themselves over a network (actually all of them want to share
a broadband internet connection :-)). But he wants to minimize the total cost of cable required as he
is a bit fastidious about the expenditure of the project. For some unknown reasons, he also wants a
second way left. I mean, he wants to know the second best cost (if there is any which may be same as
the best cost) for the project. I am sure, he is capable of solving the problem. But he is very busy with
his private affairs(?) and he will remain so. So, it is your turn to prove yourself a good programmer.
Take the challenge (if you are brave enough)...
Input
Input starts with an integer t ≤ 1000 which denotes the number of test cases to handle. Then follows
t datasets where every dataset starts with a pair of integers v (1 ≤ v ≤ 100) and e (0 ≤ e ≤ 200). v
denotes the number of neighbors and e denotes the number of allowed direct connections among them.
The following e lines contain the description of the allowed direct connections where each line is of the
form ‘start end cost’, where start and end are the two ends of the connection and cost is the cost for
the connection. All connections are bi-directional and there may be multiple connections between two
ends.
Output
There may be three cases in the output
1. No way to complete the task,
2. There is only one way to complete the task,
3. There are more than one way.
Output ‘No way’ for the first case, ‘No second way’ for the second case and an integer c for the

third case where c is the second best cost. Output for a case should start in a new line.


Sample Input
4
5 4
1 2 5
3 2 5
4 2 5
5 4 5
5 3
1 2 5
3 2 5
5 4 5
5 5
1 2 5
3 2 5
4 2 5
5 4 5
4 5 6
1 0
Sample Output
Case #1 : No second way
Case #2 : No way
Case #3 : 21
Case #4 : No second way



#include <bits/stdc++.h>
using namespace std;
const int mn = 110;
const int inf = 0x7fffffff;

int cost[mn][mn];
int cost2[mn][mn];
bool vis[mn];
int dis[mn];

int f[mn];
int far[mn][mn];
bool is[mn][mn];

int main()
{
	int T;
	scanf("%d", &T);
	for (int q = 1; q <= T; q++)
	{
		int n, m;
		scanf("%d %d", &n, &m);
		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= n; j++)
				if (i != j)
					cost2[i][j] = cost[i][j] = inf;

		for (int i = 1; i <= m; i++)
		{
			int a, b, c;
			scanf("%d %d %d", &a, &b, &c);
			if (c >= cost[a][b] && c < cost2[a][b])
				cost2[a][b] = cost2[b][a] = c;
			else if (c < cost[a][b])
			{
				cost2[a][b] = cost2[b][a] = cost[a][b];
				cost[a][b] = cost[b][a] = c;
			}
		}

		memset(is, 0, sizeof is);
		memset(vis, 0, sizeof vis);
		memset(far, 0, sizeof far);
		dis[1] = 0;
		vis[1] = 1;
		for (int i = 1; i <= n; i++)
		{
			f[i] = 1;
			dis[i] = cost[1][i];
		}
		int fr = 0;
		int sz = 0;
		while (1)
		{
			int t = -1;
			for (int i = 1; i <= n; i++)
				if (!vis[i] && dis[i] != inf && (t == -1 || dis[i] < dis[t]))
					t = i;
			if (t == -1)
				break;
			vis[t] = 1;
			sz ++;
			is[f[t]][t] = is[t][f[t]] = 1;
			fr += dis[t];

			for (int i = 1; i <= n; i++)
			{
				if (!vis[i] && cost[t][i] < dis[i])
				{
					f[i] = t;
					dis[i] = cost[t][i];
				}
				else if (vis[i] && i != t)
				{
					far[i][t] = max(far[i][f[t]], cost[f[t]][t]);
					far[t][i] = far[i][t];
				}
			}
		}
		
		printf("Case #%d : ", q);
		if (sz != n - 1)
		{
			printf("No way\n");
			continue;
		}

		int sc = inf;
		for (int i = 1; i <= n; i++)
			for (int j = i + 1; j <= n; j++)
			{
				if (!is[i][j] && cost[i][j] != inf)
					sc = min(sc, fr - far[i][j] + cost[i][j]);
				else if (is[i][j] && cost2[i][j] != inf)
					sc = min(sc, fr - cost[i][j] + cost2[i][j]);
			}
		if (sc ==  inf)
			printf("No second way\n");
		else 
			printf("%d\n", sc);
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/ummmmm/article/details/80817362
way