1021 个位数统计 (15)

给定一个k位整数N = d~k-1~*10^k-1^ + ... + d~1~*10^1^ + d~0~ (0<=d~i~<=9, i=0,...,k-1, d~k-1~>0),请编写程序统计每种不同的个位数字出现的次数。例如:给定N = 100311,则有2个0,3个1,和1个3。

输入格式:

每个输入包含1个测试用例,即一个不超过1000位的正整数N。

输出格式:

对N中每一种不同的个位数字,以D:M的格式在一行中输出该位数字D及其在N中出现的次数M。要求按D的升序输出。

输入样例:

100311

输出样例:

0:2
1:3
3:1

分析:

这道题实在是太简单了,没什么可分析的。

// B21.cpp : Defines the entry point for the console application.
//

#include <iostream>
#include <string>
using namespace std;

int main()
{
	string N;
	cin >> N;
	int temp = 0;
	int length = N.size();
	int a[10] = { 0 };
	for (int i = 0; i < length; i++)
	{
		temp = N[i] - '0';
		a[temp] ++;
	}
	for (int i = 0; i < 10; i++)
	{
		if (a[i] > 0)
		{
			cout << i << ":"<< a[i] << endl;
		}
	}
	system("pause");
	return 0;
}



猜你喜欢

转载自blog.csdn.net/piaoliangjinjin/article/details/80919043
今日推荐