poj 1017 Packets

Description
A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input
The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output
The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output file corresponding to the last “null” line of the input file.

Sample Input

0 0 4 0 0 1
7 5 1 0 0 0
0 0 0 0 0 0

Sample Output

2
1

#include<iostream>
#include<cstdio>
using namespace std;
int max(int a,int b){
    return a>b?a:b;
}
int main(){
    int s1,s2,s3,s4,s5,s6,num;
    while(cin>>s1>>s2>>s3>>s4>>s5>>s6&&(s1+s2+s3+s4+s5+s6)){
        num=0;
        num+=s6;
        num+=s5;
        s1=max(0,s1-s5*11);
        num+=s4;
        if(s2>=s4*5)
            s2-=s4*5;
        else{
            s1=max(0,s1-4*(s4*5-s2));
            s2=0;
        }
        num+=(s3+3)/4;
        s3%=4;
        if(s3){
            if(s2>=7-2*s3){
                s2-=7-2*s3;
                s1=max(0,s1-(8-s3));
            }
        else{
                s1=max(0,s1-(36-9*s3-4*s2));
                s2=0;
            }
        }
        num+=(s2+8)/9;
        s2%=9;
        if(s2) s1=max(0,s1-(36-4*s2));
        num+=(s1+35)/36;
        cout<<num<<endl;
    }return 0;
}

猜你喜欢

转载自blog.csdn.net/u012678352/article/details/80906148