Parity check

Problem Description

Fascinated with the computer games, Gabriel even forgets to study. Now she needs to finish her homework, and there is an easy problem:

f(n)=

She is required to calculate f(n) mod 2 for each given n. Can you help her?

Input

Multiple test cases. Each test case is an integer n(0≤n) in a single line.

Output

For each test case, output the answer of f(n)mod2.

Sample Input

2

Sample Output

1

Hint

Source

“浪潮杯”山东省第八届ACM大学生程序设计竞赛(感谢青岛科技大学)
#include<cstdio>
#include<cstring>
using namespace std;
const int N = 1005;
int main(){
	char str[N];
	while(scanf("%s",str)!=EOF){
		int n=strlen(str);
		int ans=0;
		for(int i=0;i<n;i++){
			ans=ans*10+(str[i]-'0');
			ans%=3;
		}
		if(ans==0) printf("0\n");
		else printf("1\n");	
	}

	return 0;
}

猜你喜欢

转载自blog.csdn.net/islittlehappy/article/details/80186156