【PAT 甲级】1005 Spell It Right (20)(20 分)

题目链接
作者: CHEN, Yue
单位: PAT联盟
时间限制: 400ms
内存限制: 64MB
代码长度限制: 16KB

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10^100^).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345
Sample Output:

one five

思路:
字符串输入,注意输入的数为0的情况。

代码:

#include <iostream>
#include <sstream>
#include <string>
#include <cstdio>
#include <algorithm>
using namespace std;
const int N = 1e3+5;

string str[]={"zero","one","two","three","four","five","six","seven","eight","nine"};
int cal(string s)
{
    int ans=0;
    for(int i=0;s[i];i++)
    {
        ans+=(s[i]-'0');
    }
    return ans;
}
int main()
{
    string ss;
    cin>>ss;
    int ans=cal(ss);
    string s[N];
    int cnt=0;
    while(ans)
    {
        s[cnt++]=str[ans%10];
        ans/=10;
    }
    for(int i=cnt-1;i>=0;i--)
    {
        cout<<s[i];
        if(i) cout<<" ";
    }
    if(!cnt) cout<<"zero";
    return 0;
}

猜你喜欢

转载自blog.csdn.net/feng_zhiyu/article/details/80849910
今日推荐