PAT甲级 1005. Spell It Right(20分)

1005. Spell It Right(20分)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

结尾无空行

Sample Output:

one five

结尾无空行
#include <iostream>
#include <vector>
using namespace std;

int main()
{
    
    
    string words;
    cin >> words;
    int sum = 0;
    for (char it : words)
    {
    
    
        sum += atoi(&it);
    }
    string hash[10] = {
    
    "zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine"};
    string res = to_string(sum);
    cout << hash[res[0] - '0'];
    for (int i = 1; i < res.size(); i++)
    {
    
    
        int num = res[i] - '0';
        cout << " " << hash[num];
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/leoabcd12/article/details/119541976