HDU 2039 三角形

http://acm.hdu.edu.cn/showproblem.php?pid=2039

Problem Description
给定三条边,请你判断一下能不能组成一个三角形。
 
Input
输入数据第一行包含一个数M,接下有M行,每行一个实例,包含三个正数A,B,C。其中A,B,C <1000;
 
Output
对于每个测试实例,如果三条边长A,B,C能组成三角形的话,输出YES,否则NO。
 
Sample Input
2
1 2 3
2 2 2
 
Sample Output
NO
YES
 
代码:
#include <bits/stdc++.h>

using namespace std;

int main()
{
    int M;
    cin>>M;
    for(int i=1;i<=M;i++)
    {
        double A,B,C;
        cin>>A>>B>>C;
        if(A+B>C&&A+C>B&&B+C>A)
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}

  

猜你喜欢

转载自www.cnblogs.com/zlrrrr/p/9226207.html
今日推荐