poj3286(dijkstra+思维)

题目链接:http://poj.org/problem?id=3268

Silver Cow Party
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 27165   Accepted: 12408

Description

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ XN). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

思路:从X位置返回时很好求,就是以X为起点的单源最短路径。而到X的路就需要点思维了。这里将整个图反向,再对X用一次迪杰斯特拉,两次路径加一起比较就可以了。。。

#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstdlib>
using namespace std;
const int INF = 0x3f3f3f3f; 
const int MAXN=1010;
bool vis[MAXN];
int lowcost[MAXN];
int cost[MAXN][MAXN];
int n,m,x;
int beg;
int d1[1010];
int d2[1010];
void Dijkstra()
{
	for (int i = 0; i < n; i++)
    {
        lowcost[i] = INF;
        vis[i] = false;
    }
    lowcost[beg]=0;
    for (int j = 0; j < n; j++)
    {
        int k = -1;
        double min = INF;
        for (int i = 0; i < n; i++)
        {
            if (!vis[i] && lowcost[i] < min)
            {
                min = lowcost[i];
                k = i;
            }
        }
        if (k == -1)
        {
            break;
        }
        vis[k] = true;
        for (int i = 0; i < n; i++)
        {
              if (!vis[i] && lowcost[k] + cost[k][i] < lowcost[i])
               lowcost[i] = lowcost[k] + cost[k][i];
        }
    }
}
void Reverse()
{
	int tem;
	for(int i=0;i<n;i++)
	{
		for(int j=i+1;j<n;j++)
		{
		  tem=cost[i][j];
		  cost[i][j]=cost[j][i];
		  cost[j][i]=tem;
	    }
	}
}
int main()
{
    int t1,t2,t3;
	scanf("%d%d%d",&n,&m,&x);
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
		  cost[i][j]=INF;
		  if(i==j)
		  cost[i][j]=0;
	    }
	}
	for(int i=0;i<m;i++)
	{
	    scanf("%d%d%d",&t1,&t2,&t3);
		cost[t1-1][t2-1]=t3;	
	}
	beg=(x-1);
	Dijkstra();
	for(int i=0;i<n;i++)
	d1[i]=lowcost[i];
	Reverse();
	Dijkstra();
	for(int i=0;i<n;i++)
	d2[i]=lowcost[i];
	int minn=0;
	for(int i=0;i<n;i++)
	{
		minn=max(minn,d1[i]+d2[i]);
	}
	printf("%d\n",minn);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/star_moon0309/article/details/80465573
今日推荐