PAT乙级 ——输出PATest

题目描述
给定一个长度不超过 10​4​​ 的、仅由英文字母构成的字符串。

请将字符重新调整顺序,按 PATestPATest.... 这样的顺序输出,并忽略其它字符。

当然,六种字符的个数不一定是一样多的,

若某种字符已经输出完,则余下的字符仍按 PATest 的顺序打印,直到所有字符都被输出。

输入格式
输入在一行中给出一个长度不超过 10​4​ 的、仅由英文字母构成的非空字符串。

输出格式
在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例
redlesPayBestPATTopTeePHPereatitAPPT

输出样例
PATestPATestPTetPTePePee


题解:

#include <iostream>
using namespace std;

int cnt[150];

int main()
{
    
    
	string s;
	cin >> s;
	
	for (int i = 0; i < s.size(); i ++) cnt[s[i]] ++;
	
	while(cnt['P'] || cnt['A'] || cnt['T'] || cnt['e'] || cnt['s'] || cnt['t'])
	{
    
    
		if(cnt['P']) cout << 'P', cnt['P'] --;
		if(cnt['A']) cout << 'A', cnt['A'] --;
		if(cnt['T']) cout << 'T', cnt['T'] --; 
		if(cnt['e']) cout << 'e', cnt['e'] --;
		if(cnt['s']) cout << 's', cnt['s'] --; 
		if(cnt['t']) cout << 't', cnt['t'] --; 
	}
	
	return 0;
} 

猜你喜欢

转载自blog.csdn.net/weixin_46239370/article/details/113862201