HDU 2476 String painter(区间dp)

String painter

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5659    Accepted Submission(s): 2695


Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 

Output
A single line contains one integer representing the answer.
 

Sample Input
 
  
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
 

Sample Output
 
  
6 7

#include<bits/stdc++.h>
using namespace std;
const int maxn=105;
char t1[maxn],t2[maxn];
int dp[maxn][maxn],ans[maxn];//dp[i][j]表示区间i~j从空白串变为t2的最少操作次数
int main()
{
    while(~scanf("%s%s",t1+1,t2+1))
    {
        int L=strlen(t1+1);
        for(int i=L;i>=1;i--)
        {
            dp[i][i]=1;
            for(int j=i+1;j<=L;j++)
            {
                dp[i][j]=dp[i+1][j]+1;
                for(int k=i+1;k<=j;k++)//枚举i个字符和k一起变
                {
                    if(t2[i]==t2[k])
                    dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]);
                }
            }
        }
        for(int i=1;i<=L;i++)
        {
            if(t1[i]==t2[i])
                ans[i]=ans[i-1];
            else
                ans[i]=ans[i-1]+1;//假设第i个字符单独一次
            for(int j=0;j<=i;j++)//枚举位置
                ans[i]=min(ans[i],ans[j]+dp[j+1][i]);
        }
        printf("%d\n",ans[L]);
    }
    return 0;
}

猜你喜欢

转载自blog.csdn.net/albertluf/article/details/80672689