杭电1018java(斯特林公式)

Big Number

Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2
10
20

Sample Output
7
19
核心是斯特林公式对阶乘的换算写法,还有就是运算位数取log10的对数+1就是所需要的值。
斯特林公式
附上java代码

import java.util.Scanner;

public class 杭电1018 {
    public static void main(String[] args)
    {
        Scanner sc=new Scanner(System.in);
        int n=sc.nextInt();
        double pi=Math.PI;      
        double e=Math.E;        
        for(int i=0;i<n;i++)
        {
            long b=sc.nextLong();
            if(b==0) {System.out.println(1);}
            else {
            double value=Math.log10(Math.sqrt(2*pi*b))+b*Math.log10(b/e);
            System.out.println((int)(value)+1);}
        }
    }
}

猜你喜欢

转载自blog.csdn.net/qq_40693171/article/details/80056490
今日推荐