PAT B 1004 成绩排名

读入n名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:每个测试输入包含1个测试用例,格式为\

  第1行:正整数n
  第2行:第1个学生的姓名 学号 成绩
  第3行:第2个学生的姓名 学号 成绩
  ... ... ...
  第n+1行:第n个学生的姓名 学号 成绩

其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112
#include<cstdio>
struct student {
	char name[15];
	char id[15];
	int score;
} a[110];

int main() {
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; i++) {
		scanf("%s %s %d", a[i].name, a[i].id, &a[i].score);
	}
	int t = 0, j = 0;
	for (int k = 0; k < n; k++) {
		if (a[k].score > a[t].score) t = k;
		if (a[k].score < a[j].score)j = k;
	}
	printf("%s %s\n%s %s\n", a[t].name, a[t].id, a[j].name, a[j].id);
	return 0;
}

或者不存储数据,直接输入的时候比较

#include<cstdio>
struct student {
	char name[15];
	char id[15];
	int score;
} temp, max, min;

int main() {
	int n;
	scanf("%d", &n);
	max.score = -1, min.score = 101;
	for (int i = 0; i < n; i++) {
		scanf("%s %s %d", temp.name, temp.id, &temp.score);
		if (temp.score > max.score) max = temp;
		if (temp.score < min.score) min = temp;
	}
	printf("%s %s\n%s %s\n", max.name, max.id, min.name, min.id);
	return 0;
}

猜你喜欢

转载自blog.csdn.net/joah_ge/article/details/80541781