5.1 PAT A1008 Elevator (20分)

1008 Elevator (20分)

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题意为计算电梯运行时间,注意如果输入同楼层的话也需要等5秒。

参考代码:

#include<cstdio>
int l[110];
int main()
{
	int n,now;
	while(scanf("%d",&n)!=EOF)
	{
		now=0;
		int sum=0;
		for(int i=0;i<n;++i)
		{
			scanf("%d",&l[i]);
			if(now<l[i])
			{
				sum=sum+(l[i]-now)*6+5;
				now=l[i];
			}
			else if(now==l[i])
				sum+=5;
			else if(now>l[i])
			{
				sum=sum+(now-l[i])*4+5;
				now=l[i];
			}	
		}
		printf("%d\n",sum);	
	}
	return 0;
 } 

猜你喜欢

转载自blog.csdn.net/qq_43590614/article/details/105161057