1102 Invert a Binary Tree (25point(s))

1102 Invert a Binary Tree (25point(s))

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.
Now it’s your turn to prove that YOU CAN invert a binary tree!

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 -

0 -
2 7

5 -
4 6
Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

1、使用静态二叉树
2、后序遍历交换左右子树即为反转二叉树

#include<bits/stdc++.h>
using namespace std;
struct node{
    
    
    int data;
    int lchild,rchild;
}Node[110];
int rootFlag[110]={
    
    false};
int n,num=0;
void print(int data){
    
    
    printf("%d",data);
    num++;
    if(num!=n) printf(" ");
    else printf("\n");
}
void inOrder(int  root){
    
    
    if(root==-1) return; 
    inOrder(Node[root].lchild);
    print(root);
    inOrder(Node[root].rchild);
}
void levelOrder(int root){
    
    
    queue<int> q;
    q.push(root);
    while(!q.empty()){
    
    
        int now=q.front();
        q.pop();
        print(now);
        if(Node[now].lchild!=-1) q.push(Node[now].lchild);
        if(Node[now].rchild!=-1) q.push(Node[now].rchild);
    }
}
void postOrder(int root){
    
    
    if(root==-1) return;
    postOrder(Node[root].lchild);
    postOrder(Node[root].rchild);
    swap(Node[root].lchild,Node[root].rchild);
}
int sToNum(char c){
    
    
    if(c=='-') return -1;
    else{
    
    
        rootFlag[c-'0']=true;
        return c-'0';
    }
}
int main(){
    
    
    scanf("%d",&n);
    char lchild,rchild;
    for(int i=0;i<n;++i){
    
    
        scanf("\n%c %c",&lchild,&rchild);//记得接收换行符,或者干脆直接用cin
        Node[i].lchild=sToNum(lchild);
        Node[i].rchild=sToNum(rchild);
    }
    int root=0;
    for(int i=0;i<n;++i){
    
    
        if(!rootFlag[i]){
    
    
            root=i;
            break;
        }
    }
    postOrder(root);
    levelOrder(root);
    num=0;
    inOrder(root);
}

猜你喜欢

转载自blog.csdn.net/weixin_44970602/article/details/112396067