SSLOJ 1896 家族

Description

若某个家族人员过于庞大,要判断两个是否是亲戚,确实还很不容易,现在给出某个亲戚关系图,求任意给出的两个人是否具有亲戚关系。

规定:x和y是亲戚,y和z是亲戚,那么x和z也是亲戚。如果x,y是亲戚,那么x的亲戚都是y的亲戚,y的亲戚也都是x的亲戚。

Input

第一行:三个整数n,m,p,(n<=50000,m<=50000,p<=50000),分别表示有n个人,m个亲戚关系,询问p对亲戚关系。以下m行:每行两个数Mi,Mj,1<=Mi,Mj<=N,表示Ai和Bi具有亲戚关系。接下来p行:每行两个数Pi,Pj,询问Pi和Pj是否具有亲戚关系。

Output

P行,每行一个’Yes’或’No’。表示第i个询问的答案为“具有”或“不具有”亲戚关系。

Sample Input

6 5 3
41 2
1 5
3 4
5 2
1 3
1 4
2 3
5 6

Sample Output

Yes
Yes
No

思路

并查集秒切好吧
code:

#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int a[50001];
int f(int x)
{
    
    
	if (a[x]==x) return x;
	else return a[x]=f(a[x]);
}
int main()
{
    
    
    int n,m,p;
	cin>>n>>m>>p;
	for (int i=1;i<=n;i++) a[i]=i;
	for (int i=0;i<m;i++)
	{
    
    
		int x,y;
		cin>>x>>y;
		a[f(x)]=f(y);
	}
	for (int i=0;i<p;i++)
	{
    
    
		int x,y;
		cin>>x>>y;
		if (f(x)==f(y)) cout<<"Yes"<<endl;
		else cout<<"No"<<endl;
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_49843717/article/details/112911783