PTA【估值一亿的AI核心代码】Java

估值一亿的AI核心代码

在这里插入图片描述

本题要求你实现一个稍微更值钱一点的 AI 英文问答程序,规则是:

无论用户说什么,首先把对方说的话在一行中原样打印出来;
消除原文中多余空格:把相邻单词间的多个空格换成 1 个空格,把行首尾的空格全部删掉,把标点符号前面的空格删掉;
把原文中所有大写英文字母变成小写,除了 I;
把原文中所有独立的 can you、could you 对应地换成 I can、I could—— 这里“独立”是指被空格或标点符号分隔开的单词;
把原文中所有独立的 I 和 me 换成 you;
把原文中所有的问号 ? 换成惊叹号 !;
在一行中输出替换后的句子作为 AI 的回答。

输入格式:

输入首先在第一行给出不超过 10 的正整数 N,随后 N 行,每行给出一句不超过 1000 个字符的、以回车结尾的用户的对话,对话为非空字符串,仅包括字母、数字、空格、可见的半角标点符号。

输出格式:

按题面要求输出,每个 AI 的回答前要加上 AI: 和一个空格。

输入样例:

6
Hello ?
Good to chat with you
can you speak Chinese?
Really?
Could you show me 5
What Is this prime? I,don 't know

输出样例:

Hello ?
AI: hello!
Good to chat with you
AI: good to chat with you
can you speak Chinese?
AI: I can speak chinese!
Really?
AI: really!
Could you show me 5
AI: I could show you 5
What Is this prime? I,don 't know
AI: what Is this prime! you,don’t know

代码

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.OutputStreamWriter;
import java.io.PrintWriter;

public class Main {
    
    
	static BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
	static PrintWriter out = new PrintWriter(new OutputStreamWriter(System.out));

	public static void main(String[] args) throws IOException {
    
    

		int n = Integer.parseInt(br.readLine());
		for (int i = 0; i < n; i++) {
    
    
			String str = br.readLine();
			out.println(str);
			char[] arr = str.toCharArray();
			String s = "";
			for (int j = 0; j < str.length(); j++) {
    
    
				if (arr[j] >= 'A' && arr[j] <= 'Z' && arr[j] != 'I') {
    
    
					arr[j] += 32;
				}
				s += arr[j];
			}
			s = s.replace("?", "!");
			s = s.replaceAll("\\s+", " ");
			s = s.replaceAll(" (\\W)", "$1");
			s = s.replaceAll("\\b(me|I)\\b", "@");
			s = s.replaceAll("\\bcould you\\b", "I could");
			s = s.replaceAll("\\bcan you\\b", "I can");
			s = s.replaceAll("@", "you");

			out.println("AI: " + s.trim());

		}

		out.flush();
	}

}

运行结果

猜你喜欢

转载自blog.csdn.net/m0_50816725/article/details/109544601
今日推荐