Ultra-QuickSort树状数组和离散化

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence
9 1 0 5 4 ,

Ultra-QuickSort produces the output
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.
Input
The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 – the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.
Output
For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.
Sample Input
5
9
1
0
5
4
3
1
2
3
0
Sample Output
6
0
问题:输入一个m,随后输入m个数。问经过几次变换能变成从小到大排序的序列;逆序数的多少就是变换次数。逆序数则可以转化成第i个数前有多少个数比它大。树状数组则用来求第i个数前有k个数小于等于它,再用i减去k即为有多少个数比它大

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define inf 1001011
typedef long long ll;
int c[inf],s[inf],n;
struct node
{
    
    
    int v,idex;
} t[inf];
bool cmp(node a,node b)
{
    
    
    return a.idex<b.idex;
}
int lowbit(int x)
{
    
    
    return x&(-x);
}
int update(int x,int v)
{
    
    
    int i;
    for(i=x;i<=n;i=i+lowbit(i))
    {
    
    
        c[i]+=v;
    }
}
int sum(int x)
{
    
    
    int i,ans=0;
    for(i=x;i>=1;i=i-lowbit(i))
        ans=ans+c[i];
    return ans;
}
int main()
{
    
    
    while(~scanf("%d",&n)&&n)
    {
    
    
        int i;
        ll ans=0;
        for(i=1; i<=n; i++)
        {
    
    
            scanf("%d",&t[i].idex);
            t[i].v=i;
        }
        sort(t+1,t+n+1,cmp);
        for(i=1;i<=n;i++)
        {
    
    
            s[t[i].v]=i;
        }
        memset(c,0,sizeof(c));
        for(i=1;i<=n;i++)
        {
    
    
            update(s[i],1);
            ans+=i-sum(s[i]);
        }
        printf("%lld\n",ans);
    }
}

猜你喜欢

转载自blog.csdn.net/m0_46312382/article/details/113089408