☀L2-009 抢红包 (25分)[PTA][模拟][sort函数compare的重载]

没有人没抢过红包吧…… 这里给出N个人之间互相发红包、抢红包的记录,请你统计一下他们抢红包的收获。

输入格式:

输入第一行给出一个正整数N(≤10​4​​),即参与发红包和抢红包的总人数,则这些人从1到N编号。随后N行,第i行给出编号为i的人发红包的记录,格式如下:

KN​1​​P​1​​⋯N​K​​P​K​​

其中K(0≤K≤20)是发出去的红包个数,N​i​​是抢到红包的人的编号,P​i​​(>0)是其抢到的红包金额(以分为单位)。注意:对于同一个人发出的红包,每人最多只能抢1次,不能重复抢。

输出格式:

按照收入金额从高到低的递减顺序输出每个人的编号和收入金额(以元为单位,输出小数点后2位)。每个人的信息占一行,两数字间有1个空格。如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。

输入样例:

10
3 2 22 10 58 8 125
5 1 345 3 211 5 233 7 13 8 101
1 7 8800
2 1 1000 2 1000
2 4 250 10 320
6 5 11 9 22 8 33 7 44 10 55 4 2
1 3 8800
2 1 23 2 123
1 8 250
4 2 121 4 516 7 112 9 10

输出样例:

1 11.63
2 3.63
8 3.63
3 2.11
7 1.69
6 -1.67
9 -2.18
10 -3.26
5 -3.26
4 -12.32

不会吧,不会吧,不会有人没抢过红包吧(老yygq了)[手动狗头] 

sort()第三个形参_compare,__comp的重写

如果收入金额有并列,则按抢到红包的个数递减输出;如果还有并列,则按个人编号递增输出。

bool f(struct mon a,struct mon b)
{
    if(a.first!=b.first)
    {
        return a.first>b.first;
    }
    else if(a.num!=b.num)
    {
        return a.num>b.num;
    }
    else if(a.second!=b.second)
    {
        return a.second<b.second;
    }
    return true;
}
#include<iostream>
#include<cmath>
#include<algorithm>
#include<cstring>
#include<set>
#include<vector>
using namespace std;
struct mon
{
    double first;
    int second;
    int num;
}money[10010];
bool f(struct mon a,struct mon b)
{
    if(a.first!=b.first)
    {
        return a.first>b.first;
    }
    else if(a.num!=b.num)
    {
        return a.num>b.num;
    }
    else if(a.second!=b.second)
    {
        return a.second<b.second;
    }
    return true;
}
int main()
{
    int N;
    cin>>N;
    for(int i=1;i<=N;i++)
    {
        int K;
        cin>>K;
        int out=0;
        while(K--)
        {
            int n,p;
            cin>>n>>p;
            out+=p;
            money[n].first+=p;
            money[n].second=n;
            money[n].num++;
        }
        money[i].first-=out;
        money[i].second=i;
    }
    sort(money+1,money+N+1,f);
    sort
    for(int i=1;i<=N;i++)
    {
        cout<<money[i].second<<" ";
        printf("%.2f\n",money[i].first/100);
    }
    return 0;
}

参考:https://blog.csdn.net/qq_43788669/article/details/103244031?biz_id=102&utm_term=L2-009%20抢红包%2025分&utm_medium=distribute.pc_search_result.none-task-blog-2~all~sobaiduweb~default-0-103244031&spm=1018.2118.3001.4187

猜你喜欢

转载自blog.csdn.net/qq_43660826/article/details/108979867