浙大PAT-1004 成绩排名 (20分/20分)

读入 n(>0)名学生的姓名、学号、成绩,分别输出成绩最高和成绩最低学生的姓名和学号。

输入格式:

每个测试输入包含 1 个测试用例,格式为

第 1 行:正整数 n
第 2 行:第 1 个学生的姓名 学号 成绩
第 3 行:第 2 个学生的姓名 学号 成绩
  ... ... ...
第 n+1 行:第 n 个学生的姓名 学号 成绩

其中姓名学号均为不超过 10 个字符的字符串,成绩为 0 到 100 之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:

对每个测试用例输出 2 行,第 1 行是成绩最高学生的姓名和学号,第 2 行是成绩最低学生的姓名和学号,字符串间有 1 空格。

输入样例:

3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:

Mike CS991301
Joe Math990112
#include <stdio.h>

struct student
{
    char name[20];
    char id[20];
    int score;
};
int main(int argc, const char * argv[]) {
    int n,max=-1,max_index=0,min=101,min_index=0;
    scanf("%d",&n);
    struct student stu[n];
    while(n--){
        scanf("%s %s %d",stu[n].name,stu[n].id,&stu[n].score);
        if(stu[n].score > max){
            max = stu[n].score;
            max_index = n;
        }
        if(stu[n].score < min){
            min = stu[n].score;
            min_index = n;
        }
    }
    printf("%s %s\n",stu[max_index].name,stu[max_index].id);
    printf("%s %s\n",stu[min_index].name,stu[min_index].id);
    return 0;
}

猜你喜欢

转载自blog.csdn.net/qq_33514421/article/details/106307027