一道题搞定MAP的应用:1022 Digital Library (30分)

1试题内容:

A Digital Library contains millions of books, stored according to their titles, authors, key words of their abstracts, publishers, and published years. Each book is assigned an unique 7-digit number as its ID. Given any query from a reader, you are supposed to output the resulting books, sorted in increasing order of their ID’s.

input

Each input file contains one test case. For each case, the first line contains a positive integer N (≤104 ) which is the total number of books. Then N blocks follow, each contains the information of a book in 6 lines:

Line #1: the 7-digit ID number;
Line #2: the book title – a string of no more than 80 characters;
Line #3: the author – a string of no more than 80 characters;
Line #4: the key words – each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
Line #5: the publisher – a string of no more than 80 characters;
Line #6: the published year – a 4-digit number which is in the range [1000, 3000].
It is assumed that each book belongs to one author only, and contains no more than 5 key words; there are no more than 1000 distinct key words in total; and there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M (≤1000) which is the number of user’s search queries. Then M lines follow, each in one of the formats shown below:

1: a book title
2: name of an author
3: a key word
4: name of a publisher
5: a 4-digit number representing the year

output

For each query, first print the original query in a line, then output the resulting book ID’s in increasing order, each occupying a line. If no book is found, print Not Found instead.

Sample Input
3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output
1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

2题意分析

模拟数字图书馆的查询功能。会给出n本书的信息,以及m个需要查询的命令,数字标号对应相应的命令,数字编号后⾯的字符串是查询的搜索词,要求输出这⾏命令以及输出满⾜条件的书的did,如果⼀个都没有找到,输出Not Found

3重点注意

  1. 输出的时候需要注意did是一个固定7位数字,若没有7位需要补零
  2. 关键字一栏需要根据空格继续分割标记
  3. 注意换行符,所导致的输入问题,需要用getchar,进行消除
  4. 使用mp<string ,set>的方式进行标志更方便快捷
#include <cstdio>
#include <iostream>
#include <map>
#include <string>
#include <set>
using namespace std;
const int mmax = 10010; 
map<string,set<int>> blab;
string temp;
int n,m,bid;
int main(){
    
    
	scanf("%d",&n);
	for(int i=0;i<n;i++){
    
    
		scanf("%d",&bid);
		char c = getchar();
		for(int j=1;j<=5;j++){
    
    
			getline(cin,temp);
			if(j==3){
    
    
				int k;string tt;
				while(temp.size()){
    
    
					k = 0;
					while(temp[k]!=' '&&k!=temp.size()){
    
    
						tt += temp[k];
						k++;
					}
					blab[tt].insert(bid);
					tt = "";
					temp.erase(0,k+1);
				}
			}else{
    
    
				blab[temp].insert(bid);
			}			
		}
	}
	scanf("%d",&m);
	char c = getchar();
	string num;
	for(int i=0;i<m;i++){
    
    
		getline(cin,temp);
		cout<<temp<<endl;
		temp = temp.erase(0,3);
		int len = blab[temp].size();
		if(len){
    
    
			for(set<int>::iterator it = blab[temp].begin();it!=blab[temp].end();it++) 
			printf("%07d\n",*it);
		}else{
    
    
			cout<<"Not Found"<<endl;
		}
	}	
	return  0;
}

4 知识补充map

在头文件==<map>==中:

4.1如何理解map中的映射:

  • 相当于array[0] = 5.20,是将int 型映射到double型。
  • map 可以将任何基本类型(包括STL容器)映射到任何基本类型(包括STL容器)。

4.2如何定义map:

  • 字符串到整型的映射:map<string,int> mp; 字符串必须只能用string表示。
  • 字符型到整型的映射:map<char,int> mp;
  • set容器到字符串类型的映射:map<string,set<int>> mp;可以表示mp[“paopap”] = {11,12,15,16,17},并且里面的值是不能相同,按照升序的顺序排列。具体例题可见:

4.3map的访问:

  1. 通过下标访问:
map<char,int> mp;
mp['c'] = 20;
mp['c'] = 30printf("%d\n",mp['c']); // 结果为30
  1. 通过迭代器访问
for(auto it = j.begin(); it!= m.end();it++){
    
    
	cout<< it->fist<<" "<< it->second << endl;
}
// 访问map的第⼀个元素,输出它的键和值
cout << m.begin()->first << " " << m.begin()->second << endl;
// 访问map的最后⼀个元素,输出它的键和值
cout << m.rbegin()->first << " " << m.rbegin()->second << endl;
// 输出map的元素个数
cout << m.size() << endl;

4.4map常用函数:

  1. find()
    find(key)返回键为key 的映射的迭代器,时间复杂度为O(log~N),N为map中映射的个数。
  2. erase()
    删除单个元素:mp.erase(it) // it为迭代器;mp.erase(‘b’)
    删除一个区间内的所有元素:mp.erase(first,last) //
  3. size() 获得map映射的对数
  4. clear() 清空map
map<char,int> mp;
mp['a'] = 1;
map <char,int> mp;
int main(){
    
    
	mp['a'] = 1;
	mp['b'] = 2;
	auto it = mp.find('a'); //auto 可以让编译器根据初始值类型直接推断变量的类型
	printf("%c %d\n",it->first,it->second);
	mp.erase(it,mp.end());//删除it之后的所有映射。
	mp.erase(it) //就把mp['a']删除了
	mp.clear();
}

4.5常见用途:

  1. 需要建立字符(或字符串)与整数之间映射的题目,使用map可以减少代码量。
  2. 判断大整数或者其他类型数据是否存在的题目,可以把map当bool数组用
  3. 字符串和字符串的映射也可能会遇到。
    叮叮~具体应用可以参考本人写的文章:PAT1018

勉励
加油ヾ(◍°∇°◍)ノ゙

如果觉得我的文章对你有所帮助与启发,点赞给我个鼓励吧(づ ̄3 ̄)づ╭❤
关注我和我一起共勉加油吧!
如果文章有错误,还望不吝指教!

猜你喜欢

转载自blog.csdn.net/qq_43992949/article/details/107153114