21行代码AC_HDU 5935 Car【贪心, 精度】

励志用更少的代码做更高效的表达


Problem Description
Ruins is driving a car to participating in a programming contest. As on a very tight schedule, he will drive the car without any slow down, so the speed of the car is non-decrease real number.

Of course, his speeding caught the attention of the traffic police. Police record N positions of Ruins without time mark, the only thing they know is every position is recorded at an integer time point and Ruins started at 0.

Now they want to know the minimum time that Ruins used to pass the last position.

Input
First line contains an integer T, which indicates the number of test cases.

Every test case begins with an integers N, which is the number of the recorded positions.

The second line contains N numbers a1, a2, ⋯, aN, indicating the recorded positions.

Limits
1≤T≤100
1≤N≤105
0< ai≤109
ai< ai+1

Output
For every test case, you should output ‘Case #x: y’, where x indicates the case number and counts from 1 and y is the minimum time.

Sample Input
1
3
6 11 21

Sample Output
Case #1: 4


由于速度不会减小,且花费时间都是整数,则倒着来
最后两点之间的速度最大,且时间最小,v=a[n]-a[n-1];
这之前的速度<=之后的速度

注意:车速可以是小数, 小时数只能是整数, 车速每段路程一定增加。


代码展示

#include<bits/stdc++.h>
#define maxn 100005
int main() {
    
    
   int t; scanf("%d",&t);
   int n,sum;
   int a[maxn];
   for(int cas=1;cas<=t;cas++) {
    
    
       scanf("%d",&n);
       for(int i=1;i<=n;i++)  scanf("%d",&a[i]);
       double v=(a[n]-a[n-1]);
       sum=1;
       for(int i=n-1;i>=1;i--)
           for(int j=(a[i]-a[i-1])/v; ;j++) {
    
    
               double y=(a[i]-a[i-1])*1.0/j;
               if(y<=v) {
    
    
                   sum+=j; v=y; break;
               }
           }
       printf("Case #%d: %d\n",cas,sum);
   }
return 0; }

日拱一卒,功不唐捐

猜你喜欢

转载自blog.csdn.net/weixin_43899069/article/details/109146507
今日推荐