A1028 List Sorting (25 分)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input Specification:

Each input file contains one test case. For each case, the first line contains two integers N (≤10​5​​) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output Specification:

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1:

3 1
000007 James 85
000010 Amy 90
000001 Zoe 60

Sample Output 1:

000001 Zoe 60
000007 James 85
000010 Amy 90

Sample Input 2:

4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98

Sample Output 2:

000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60

Sample Input 3:

4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90

Sample Output 3:

000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

题意:

给出N (≤10​5​​)个考生的准考证号 ID (a 6-digit number)、姓名(a string with no more than 8 characters without space)、分数 (an integer between 0 and 100, inclusive),并输入参数C,按照C的取值进行排序:

  1. C == 1, 按准考证号从小到大排序
  2. C == 2, 按姓名字典序从小到大排序,若姓名相同,按照准考证从小到大
  3. C == 3, 按分数从小到大排序,分数相同按照准考证从小到大

注意:

  1. 输入 000001时,存储为int型时,存入的为 1; 因此最终输出时,用 %06d 用0来补齐六位
#include <cstdio>
int main(){
    int n;
    scanf("%d", &n);
    printf("%d", n);
    return 0;
}

#########################
0000010
10
Process returned 0 (0x0)   execution time : 3.336 s
Press any key to continue.

 本题代码实现如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 100010;
struct Student{
  int id;
  char name[10];
  int score;
}stu[maxn];

bool cmp1(Student a, Student b){
  return a.id < b.id;
}

bool cmp2(Student a, Student b){
  int s = strcmp(a.name, b.name);
  if(s != 0)
    return s < 0;
  else 
    return a.id < b.id;
}

bool cmp3(Student a, Student b){
  if(a.score != b.score)
    return a.score < b.score;
  else 
    return a.id < b.id;
}

int main(){
  int n, c;
  scanf("%d %d", &n, &c);
  for(int i = 0; i < n; i++){
    scanf("%d %s %d", &stu[i].id, stu[i].name, &stu[i].score);
  }
  if(c == 1)
    sort(stu, stu + n, cmp1);
  else if(c == 2)
    sort(stu, stu + n, cmp2);
  else
    sort(stu, stu + n, cmp3);
  for(int i = 0; i < n; i++){
    printf("%06d %s %d\n", stu[i].id, stu[i].name, stu[i].score);
  }
  return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_35093872/article/details/86561018