Team Queue (团队队列+插队)

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example.
In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue.

Your task is to write a program that simulates such a team queue.
 

Input

The input will contain one or more test cases. Each test case begins with the number of teams t (1<=t<=1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements.

Finally, a list of commands follows. There are three different kinds of commands:

ENQUEUE x - enter element x into the team queue
DEQUEUE - process the first element and remove it from the queue
STOP - end of test case
The input will be terminated by a value of 0 for t.
 

Output

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

Sample Input

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

Sample Output

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001

题意描述:就是给一些人分队,然后去排队。如果,队列里面有和自己一对的人在前面排队,自己可以插到自己队伍后面的最后一位;输入ENQUEUE 后再输入一个数,代表要插入的数;输入DEQUEUE 后输出队列的最后一个人的序号;

解题思路:先用map,在输入的时候将每个数标记他所在的队列;刚开始想过用数组但数组要开到1000000太占空间;然后还需要一个数组来判断这个人的队友是否有人在前面插队,如果有的话这个人就可以插到自己队伍的最后面了;当然队列中是不能插队的,所以要想站到自己队伍的后面就只有每个队伍都有单独的队列,然后有一个队列给这些队列的序号排队,如果最后一个队列的人全部出队则在序号队列中最后一位的队列序号也出队,并且在数组中标记这个队伍已经没有人在排队了;如果再有这个队伍的人来排队就需要从最后面继续排队,并且让自己的队列序号进入序号队列;

注意每两个样例之间有一个空行;还要注意数组大小,我就运行错误了3次;

下面是完整代码:

#include<stdio.h>
#include<map>
#include<iostream>
#include<queue>
#include<string.h>
using namespace std;
int main()
{
	int x,n,i,j,k,t=1;
	char s[100];
	int a[1020];
	while(scanf("%d",&n),n!=0)
	{
		memset(a,0,sizeof(a));
		map<int,int> m;
		for(i=1;i<=n;i++)
		{
			scanf("%d",&x);
			for(j=0;j<x;j++)
			{
				scanf("%d",&k);
				m[k]=i;
			}
		}
		queue<int> q[1010],q1;
		printf("Scenario #%d\n",t++);
		while(scanf("%s",s),s[0]!='S')
		{
			if(s[0]=='E')
			{
				scanf("%d",&k);
				q[m[k]].push(k);
				if(a[m[k]]==0)
				{
					q1.push(m[k]);
					a[m[k]]=1;
				}
			//	q[m[k]].push(k);
			}
			else
			{
				printf("%d\n",q[q1.front()].front());
				q[q1.front()].pop();
				if(q[q1.front()].empty())
				{
					a[q1.front()]=0;
					q1.pop();
				}
			}
		}
		printf("\n");
	}
	return 0;
}

猜你喜欢

转载自blog.csdn.net/weixin_44584292/article/details/102953047