PAT 12. 统计大写辅音字母 使用python实现

英文辅音字母是除A、E、I、O、U以外的字母。本题要求编写程序,统计给定字符串中大写辅音字母的个数。

输入格式:

输入在一行中给出一个不超过80个字符、并以回车结束的字符串。

输出格式:

输出在一行中给出字符串中大写辅音字母的个数。

输入样例:

HELLO World!

输出样例:

4

参考 代码

s=input()
count=0
for i in range(len(s)):
    if "A"<=s[i]<="Z" and s[i]!="A" and s[i]!="E" and s[i]!="I" and s[i]!="O" and s[i]!="U":
        count=count+1
print(count)

猜你喜欢

转载自blog.csdn.net/qq_24483663/article/details/107411974
今日推荐