多校第二场——1006 The Oculus

Problem Description
Let’s define the Fibonacci sequence F1,F2,… as F1=1,F2=2,Fi=Fi−1+Fi−2 (i≥3).

It’s well known that every positive integer x has its unique Fibonacci representation (b1,b2,…,bn) such that:

· b1×F1+b2×F2+⋯+bn×Fn=x.

· bn=1, and for each i (1≤i<n), bi∈{0,1} always holds.

· For each i (1≤i<n), bi×bi+1=0 always holds.

For example, 4=(1,0,1), 5=(0,0,0,1), and 20=(0,1,0,1,0,1) because 20=F2+F4+F6=2+5+13.

There are two positive integers A and B written in Fibonacci representation, Skywalkert calculated the product of A and B and written the result C in Fibonacci representation. Assume the Fibonacci representation of C is (b1,b2,…,bn), Little Q then selected a bit k (1≤k<n) such that bk=1 and modified bk to 0.

It is so slow for Skywalkert to calculate the correct result again using Fast Fourier Transform and tedious reduction. Please help Skywalkert to find which bit k was modified.

Input
The first line of the input contains a single integer T (1≤T≤10000), the number of test cases.

For each case, the first line of the input contains the Fibonacci representation of A, the second line contains the Fibonacci representation of B, and the third line contains the Fibonacci representation of modified C.

Each line starts with an integer n, denoting the length of the Fibonacci representation, followed by n integers b1,b2,…,bn, denoting the value of each bit.

It is guaranteed that:

· 1≤|A|,|B|≤1000000.

· 2≤|C|≤|A|+|B|+1.

·∑|A|,∑|B|≤5000000.

Output
For each test case, output a single line containing an integer, the value of k.

Sample Input
1
3 1 0 1
4 0 0 0 1
6 0 1 0 0 0 1

Sample Output
4

思路:简单题,暴力就能过

代码:

#include<bits/stdc++.h>
typedef unsigned long long ull;
const int N = 3000005;
using namespace std;
ull f[N];
int main()
{

    f[1] = 1;
    f[2] = 2;
    for (int i = 3; i < N; i++)
    {
        f[i] = f[i - 1] + f[i - 2];
    }
    int T;
    scanf("%d", &T);
    ull A, B, C;
    while (T--)
    {
        int n;
        ull res = 0;
        scanf("%d", &n);
        for (int i = 1; i <= n; i++)
        {
            int x;
            scanf("%d", &x);
            if (x)
            {
                res += f[i];
            }
        }
        A = res;
        res = 0;
        scanf("%d", &n);
        for (int i = 1; i <= n; i++)
        {
            int x;
            scanf("%d", &x);
            if (x)
            {
                res += f[i];
            }
        }
        B = res;
        res = 0;
        scanf("%d", &n);
        for (int i = 1; i <= n; i++)
        {
            int x;
            scanf("%d", &x);
            if (x)
            {
                res += f[i];
            }
        }
        C = res;
        A *= B;
        int i=1;
        while(C + f[i] != A)
        {
            i++;
        }
        printf("%d\n", i);
    }
}

猜你喜欢

转载自blog.csdn.net/weixin_43330910/article/details/107617332