POJ - 2528——Mayor's posters (贴海报)线段树+离散化

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules:
  • Every candidate can place exactly one poster on the wall.
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown).
  • The wall is divided into segments and the width of each segment is one byte.
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections.
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall.
Input
The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.
Output
For each input data set print the number of visible posters after all the posters are placed.

The picture below illustrates the case of the sample input.
Sample Input
1
5
1 4
2 6
8 10
3 4
7 10
Sample Output
4

离散化缺陷,比如1,10,1,3,5,10,这里应该有3个海报可见,可离散化后会把4这个点忽略。变为了2.
思路:把每一张海报设置编号,一段区域中有多个海报区域值为0.
数组模拟线段树:
#include<algorithm>
#include<string.h>
#include<stdio.h>
#define M 30000
using namespace std;
struct node
{
    int k,p;
}a[M<<2];
int b[M<<2],c[M<<2],d[M<<2];
int cmp(node a,node b)
{
    return a.k<b.k;
}
void down(int k)
{
    c[k<<1]=c[k];
    c[k<<1|1]=c[k];
    d[k<<1]=c[k];
    d[k<<1|1]=c[k];
    c[k]=0;
}
void search_trie(int k)
{
    if(d[k]<0)
        return ;
    if(d[k])
    {
        b[d[k]]=1;
        return ;
    }
    if(c[k]) down(k);
    search_trie(k<<1);
    search_trie(k<<1|1);
}
void update(int ll,int rr,int l,int r,int k,int x)
{
    int mid;
    if(ll<=l&&rr>=r)
    {
        d[k]=x;
        c[k]=x;
        return ;
    }
    if(c[k]) down(k);
    mid=(r+l)>>1;
    if(mid>=rr) update(ll,rr,l,mid,k<<1,x);
    else if(mid<ll) update(ll,rr,mid+1,r,k<<1|1,x);
    else
    {
        update(ll,rr,l,mid,k<<1,x);
        update(ll,rr,mid+1,r,k<<1|1,x);
    }
    if( !d[k<<1] || !d[k<<1|1] || d[k<<1] != d[k<<1|1] )
        d[k] = 0 ;
    else
        d[k] = d[k<<1|1] ;
}
int main()
{
    int t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
        {
            scanf("%d%d",&a[i].k,&a[i+n].k);
            a[i].p=i;
            a[i+n].p=i+n;
        }
        sort(a+1,a+2*n+1,cmp);

        int p=0,temp=-1,ans=0;
        for(int i=1;i<=2*n;i++)
        {
            if(a[i].k==temp)
                a[i].k=p;
            else
            {
                temp=a[i].k;
                a[i].k=++p;
            }
            b[a[i].p]=a[i].k;
        }
        memset(c,0,sizeof(c));
        memset(d,-1,sizeof(d));
        temp=0;
        for(int i=1;i<=n;i++)
        {
            update(b[i],b[i+n],1,p,1,++temp);
        }
        memset(b,0,sizeof(b));
        search_trie(1);
        for(int i=1;i<=p;i++)
        {
            if(b[i])
            {
                ans++;
            }
        }
        printf("%d\n",ans);
    }
}

 
 


猜你喜欢

转载自blog.csdn.net/weixin_41380961/article/details/80499365
今日推荐