(PAT)判断回文字符串

本题要求编写函数,判断给定的一串字符是否为“回文”。所谓“回文”是指顺读和倒读都一样的字符串。如“XYZYX”和“xyzzyx”都是回文。

函数palindrome判断输入字符串char *s是否为回文。若是则返回true,否则返回false。

输入样例1:
thisistrueurtsisiht

输出样例1:
Yes
thisistrueurtsisiht

输入样例2:
thisisnottrue

输出样例2:
No
thisisnottrue

#include <stdio.h>
#include <string.h>

#define MAXN 20
typedef enum {false, true} bool;

bool palindrome( char *s );

int main()
{
    char s[MAXN];

    scanf("%s", s);
    if ( palindrome(s)==true )
        printf("Yes\n");
    else
        printf("No\n");
    printf("%s\n", s);

    return 0;
}
bool palindrome( char *s )
{
	int i,j,k;
	char a[MAXN];
	for(i=0;s[i]!='\0';i++);
	for(j=0,k=i-1;j<i;j++,k--)
	a[j]=s[k]; 				//将s[]倒叙存放在a[]中
	for(i=0;a[i]!='\0';i++){
		if(a[i]!=s[i])		//比较a[]和s[],若完全一样则为true
		return false;
	}
	return true;
}

猜你喜欢

转载自blog.csdn.net/Dax1_/article/details/105982309