杭电oj 2024

Problem Description

输入一个字符串,判断其是否是C的合法标识符。

Input

输入数据包含多个测试实例,数据的第一行是一个整数n,表示测试实例的个数,然后是n行输入数据,每行是一个长度不超过50的字符串。

Output

对于每组输入数据,输出一行。如果输入数据是C的合法标识符,则输出"yes",否则,输出“no”。

Sample Input

 

3 12ajf fi8x_a ff ai_2

Sample Output

 

no yes no

/*
    判断 字符串符合c变量标准 
    cin.getline();

    bool型 isdigit 、isalpha 

    continue用法 
*/

/*
	判断 字符串符合c变量标准 
	cin.getline();

	bool型 isdigit 、isalpha 

	continue用法 
*/


#include <iostream>
#include <cstring>
using namespace std;

char s[51];
int main() {
	int t;
	cin >> t;
	getchar();
	while(t--) {
		cin.getline(s,51);
		bool flag = true;
		int len  = strlen(s);
		if(isdigit(s[0])) {
			cout << "no"<<endl;
			continue;
		}


	for(int i = 0; i < len; i++) {
		if(s[i] != '_' && isdigit(s[i]) == 0 && isalpha(s[i]) == 0) {
			flag = false;
			break;
		}
	}
	if(flag)  cout << "yes" << endl;
	else cout << "no" << endl;


	}

	return 0;
}















猜你喜欢

转载自blog.csdn.net/qing_feng__/article/details/86747033